Registry performance issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 16:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2026 - 15:55 UTC

Identified

The fly.io registry is currently experiencing capacity constraints that reduced performance and may lead to temporary high latency or failed pushes. We are currently working to add capacity and restore service.
Posted Jul 09, 2026 - 15:33 UTC
This incident affected: Deployments.