Managed Postgres control plane instability in NRT (Tokyo)

Incident Report for Fly.io

Identified

The issue has been identified and a fix is being implemented. Users with clusters in NRT may continue to see instability at this time
Posted Apr 10, 2026 - 20:13 UTC

Investigating

We are investigating instability in the MPG control plane in the NRT (Toyko, Japan) region causing unexpected cluster failovers. Clusters return to health shortly after, but some users with clusters in NRT may see dropped connections or degraded performance at this time.
Posted Apr 10, 2026 - 18:42 UTC
This incident affects: Managed Postgres (Management Plane - NRT).