Increased DNS resolution errors

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Aug 11, 2022 - 09:16 UTC

Monitoring

Rollback has restored access to DNS services.
Posted Aug 10, 2022 - 21:15 UTC

Identified

We are rolling back a networking change that might have interfered with DNS packets destined for external addresses.
Posted Aug 10, 2022 - 21:06 UTC

Update

We are continuing to investigate this issue.
Posted Aug 10, 2022 - 20:44 UTC

Update

We are investigating broken DNS resolution, as well as failures in UDP Anycast services on port 53. Applications may not currently be able to resolve public DNS records or accept UDP traffic on Anycast port 53.
Posted Aug 10, 2022 - 20:44 UTC

Investigating

We are investigating reports of an increase in DNS resolution errors for apps running on Fly.io.
Posted Aug 10, 2022 - 20:32 UTC
This incident affected: DNS (Fly Machine .internal DNS).