Degraded network in AMS

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 10:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 09, 2026 - 09:47 UTC

Update

We are still working on restoring the MPG clusters. Most of them should be operational already.
Posted Feb 09, 2026 - 08:58 UTC

Update

Affected hosts are starting to come back online. We are working on restoring affected MPG clusters.
Posted Feb 09, 2026 - 07:42 UTC

Identified

One of our upstream providers is experiencing a major power issue in their AMS datacenter. Managed Postgres instances in AMS are experiencing an outage as our control plane for Managed Postgres is taken down by the incident.
Posted Feb 09, 2026 - 07:34 UTC

Investigating

One of our upstream providers is performing an emergency DC maintenance. You may see degraded connectivity on some of your apps in AMS. Most apps in AMS are not affected.
Posted Feb 09, 2026 - 07:17 UTC
This incident affected: Regional Availability (AMS - Amsterdam, Netherlands) and Managed Postgres (Management Plane - AMS).