Networking issues in SIN

Incident Report for Fly.io

Update

All MPGs in SIN are reachable again. We are seeing high latency to the affected provider. This may affect a subset of machines hosted in SIN.
Posted May 20, 2026 - 08:59 UTC

Identified

One of our upstreams is experiencing high packet loss and latency. We are actively working with them.
Posted May 20, 2026 - 08:23 UTC

Investigating

Machines may see high packet loss. Some MPGs are unable to connect to their config store and may be unreachable right now.
Posted May 20, 2026 - 08:06 UTC
This incident affects: Managed Postgres (Management Plane - SIN) and Regional Availability (SIN - Singapore).