GraphQL API Issue
Incident Report for Fly.io
Resolved
GraphQL API and Dashboard are fully operational again.
Posted Jul 29, 2024 - 14:44 UTC
Update
We are still seeing sporadic errors and we are continuing to investigate.
Posted Jul 29, 2024 - 12:49 UTC
Update
GraphQL-based operations appear to be succeeding and the Dashboard is available. We are continuing to monitor for further issues.
Posted Jul 29, 2024 - 11:04 UTC
Monitoring
A fix has been rolled out and we are currently monitoring.
Posted Jul 29, 2024 - 10:40 UTC
Update
An initial fix is being tested and we are looking to roll it out shortly.
Posted Jul 29, 2024 - 10:21 UTC
Identified
We have identified an issue with our GraphQL API which many Fly.io services interact with. The Dashboard, Flyctl deployments and the Machines API are currently affected. Most users will will experience 503 errors when deploying from flyctl or GitHub Actions at this time.
Posted Jul 29, 2024 - 08:47 UTC
Update
We are continuing to investigate this issue. Users may experience intermittent 503 errors when trying to access the Dashboard or interact with services that rely on the GraphQL API (i.e Flyctl)
Posted Jul 29, 2024 - 08:33 UTC
Investigating
We are currently investigating an issue with the Fly.io dashboard where users are unable to log in
Posted Jul 29, 2024 - 08:31 UTC
This incident affected: Dashboard, Machines API, and Deployments.