Network issues in BOM (Mumbai, India)

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 16:51 UTC

Update

We are continuing to work with our external connectivity providers to address the service degradation caused by multiple submarine cable outages. Traffic between India and Europe/US East is impacted. Since this is an external incident, some degradation may still occur. We'll provide another update as soon as we have more information.
Posted Sep 06, 2025 - 13:45 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 06, 2025 - 05:27 UTC

Identified

We've identified an issue with an upstream provider and are working to resolve it.
Posted Sep 06, 2025 - 04:16 UTC

Investigating

We are investigating network issues in BOM region. Apps may experience higher latency or packet loss.
Posted Sep 06, 2025 - 03:20 UTC
This incident affected: Regional Availability (BOM - Mumbai, India).